package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]{1,2}\d[a-zA-Z\d]?\s?\d[a-zA-Z]{2}$`)
var str = `
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}