$re = '/\n\t(?!\t)/m';
$str = 'dir
subdir1
subdir2
file.ext';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);