re = /^(?![^!?.\n\r]*[!?.])\w+:/m
str = 'Choose: blah blah blah 123 for 100\'ish characters, this matches
Choose: blah blah blah 123! for 100\'ish characters?, .this potential match fails for the ! ? and .'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end