package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[0-9A-Za-z][0-9A-Za-z-]{0,62})(?:\.(?:[0-9A-Za-z][0-9A-Za-z-]{0,62}))*(\.?|\b)`)
var str = `Hostname: camp-ds-001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}