$re = '/\b(f.ck|fu.k|fuc.)(\b|ed|er|ing|er)/m';
$str = 'fuck
f*ck
fucker
trafficking
fickle
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);