re = /^(?=\d)(?:\d+w\h*)?(?:\b\d+d\h*)?(?:\b\d+h\h*)?(?:\b\d+m)?$/m
str = '1w 3d 5h 3m
32d 5h 3m
3pp 2h 35m
2d 5qq 3m
2d 35m
3h 1w
1w3d5h3m
1w 3d 5h 3m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end