const regex = /^(?=\d)(?:\d+w\h)?(?:\b\d+d\h)?(?:\b\d+h\h)?(?:\b\d+m)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\d)(?:\\d+w\\h)?(?:\\b\\d+d\\h)?(?:\\b\\d+h\\h)?(?:\\b\\d+m)?$', 'gm')
const str = `1w 3d 5h 3m
32d 5h 3m
3pp 2h 35m
2d 5qq 3m
2d 35m
3h 1w
1w3d5h3m
1w 3d 5h 3m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}