re = /(?<![^a-zA-Z\s])((\+|00(\s|\s?-\s?)?)31(\s|\s?-\s?)?(\(0\)[-\s]?)?|0)[1-9]((\s|\s?-\s?)?[0-9])((\s|\s?-\s?)?[0-9])((\s|\s?-\s?)?[0-9])\s?[0-9]\s?[0-9]\s?[0-9]\s?[0-9]\s?[0-9](?![^a-zA-Z\s])/m
str = 'Mijn telefoonnnummer is 0612131415
Mijn telefoonnnummer is 06-12345678
Mijn telefoonnummer0612131415email
Is shouldn\'t detect
000006121314150000
-0612131415-
00-0612131415-00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end