import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(ATU\\d{8}|BE[01]\\d{9}|BG\\d{9,10}|CY\\d{8}[LX]|CZ\\d{8,10}|DE\\d{9}|DK\\d{8}|EE\\d{9}|EL\\d{9}|ES[\\dA-Z]\\d{7}[\\dA-Z]|FI\\d{8}|FR[\\dA-Z]{2}\\d{9}|HR\\d{11}|HU\\d{8}|IE\\d{7}[A-Z]{2}|IT\\d{11}|LT(\\d{9}|\\d{12})|LU\\d{8}|LV\\d{11}|MT\\d{8}|NL\\d{9}B\\d{2}|PL\\d{10}|PT\\d{9}|RO\\d{2,10}|SE\\d{12}|SI\\d{8}|SK\\d{10})\\b";
final String string = "ATU12345678\n"
+ "BE1234567890\n"
+ "BG123456789\n"
+ "HR12345678901\n"
+ "CY12345678X\n"
+ "CZ12345678\n"
+ "DK12345678\n"
+ "EE123456789\n"
+ "FI12345678\n"
+ "FR12345678901\n"
+ "DE123456789\n"
+ "EL123456789\n"
+ "HU12345678\n"
+ "IE1234567WA\n"
+ "IT12345678901\n"
+ "LV12345678901\n"
+ "LT123456789\n"
+ "LU12345678\n"
+ "MT12345678\n"
+ "NL123456789B01\n"
+ "PL1234567890\n"
+ "PT123456789\n"
+ "RO1234567890\n"
+ "SK1234567890\n"
+ "SI12345678\n"
+ "ESX12345678\n"
+ "SE123456789012";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}