import re
regex = re.compile(r"(?:(?:\"|'|\]|\}|\\|\d|(?:nan|infinity|true|false|null|undefined|symbol|math)|\`|\-|\+)+[)]*;?((?:\s|-|~|!|{}|\|\||\+)*.*(?:.*=.*)))", flags=re.MULTILINE)
test_str = ("<ResourceDictionary\n"
"xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\"\n"
"xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\"\n"
"xmlns:System=\"clr-namespace:System;assembly=mscorlib\"\n"
"xmlns:Diag=\"clr-namespace:System.Diagnostics;assembly=system\">\n"
" <ObjectDataProvider x:Key=\"LaunchCalch\" ObjectType=\"{x:Type Diag:Process}\" MethodName=\"Start\">\n"
" <ObjectDataProvider.MethodParameters>\n"
" <System:String>cmd.exe</System:String>\n"
" <System:String>/c calc.exe</System:String>\n"
" </ObjectDataProvider.MethodParameters>\n"
" </ObjectDataProvider>\n"
"</ResourceDictionary>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")