$re = '/^[a-z0-9-.\x27\s]+$/mi';
$str = 'Kevin O\'Leary';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);