# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<iframe\s?(?:width="(?:\d+)?")?\s?(?:height="(?:\d+)?")?\s*(.*src="https:\/\/www\.(?:youtube|vimeo)\.com.*)<\/iframe>/<div class="videoWrapper"><iframe $1<\/iframe><\/div>/gm;t' <<< "<iframe width=\"1228\" height=\"691\" src=\"https://www.youtube.com/embed/FBtUTYFYaG4\" title=\"YouTube video player\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>"