#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(?i)<p\s+id=[0-9]+\s*>(.+?)<\/P>"
Local $sString = "<P " & @CRLF & _
"ID=2630932>" & @CRLF & _
"Background " & @CRLF & _
"Adrenal cortex oncocytic carcinoma (AOC) represents an exceptional pathological entity, since only 22 cases have been documented in the literature so far." & @CRLF & _
"</P>" & @CRLF & _
"" & @CRLF & _
"<P ID=2630932>" & @CRLF & _
"Background" & @CRLF & _
"Adrenal cortex oncocytic carcinoma (AOC) represents an exceptional pathological entity, since only 22 cases have been documented in the literature so far." & @CRLF & _
"</P>" & @CRLF & _
"" & @CRLF & _
"<P ID=2630932 >" & @CRLF & _
"Background" & @CRLF & _
"Adrenal cortex oncocytic carcinoma (AOC) represents an exceptional pathological entity, since only 22 cases have been documented in the literature so far." & @CRLF & _
"</P>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")