// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<\?php echo L10n\:\:icon\('timeago'\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)").unwrap();
let string = "<?php echo L10n::icon('timeago'); ?>
<?php echo UI::timeago($Camera->iso_8601_processed, $Camera->processed); ?>";
let substitution = "$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}