#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "items\[\d+\]\[debit\]"
Local $sString = "<input name="items[1][debit]" type="number">" & @CRLF & _
"<input name="items[341][debit]" type="number">" & @CRLF & _
"<input name="items[31][debit]" type="number">" & @CRLF & _
"<input name="items[431][debit]" type="number">" & @CRLF & _
"<input type="button" value="SUM" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")