package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}$`)
var str = `140.110.122.231`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}