# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?\/)(?=[^\/]+=).*$"
test_str = ("my-file-path/wefw/wefw/wef/wfweof=wefonwe/wfewoi=weoif/\n"
"my-file-path/wefw/wef/ef=wefonwe/wfewoi=weoif/\n"
"my-file-path/wef/wfe/wefw/wef/ef=wefonwe/wfewoi=weoif/\n\n"
"Output:\n\n"
"file_paths\n"
"my-file-path/wefw/wefw/wef/\n"
"my-file-path/wefw/wef/\n"
"my-file-path/wef/wfe/wefw/wef/\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.