re = /^[A-Za-z0-9 ]+$/m
str = 'mayank
Mayank
mayank12
m`ayank
M\'ayank
may-ank
mayank
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end