$re = '/^(?!admin|public)([a-z0-9]+)\/?([a-zA-Z0-9._\/]+)?$/m';
$str = 'api/
api
api.set/
api/newsfeed.get/
api/news.getcomments
d/
d/26
d/26/
d/26/taxo
mypanel/admin
public/kekwo
publication/
publication
news/21
news
news/
d
d/26
over9000
video100500/
user/dreamer
user/HateYouCheater
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);