using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?[ ]+.*?[ ]+(.*?)[ ]";
string input = @"Windows SERVERMAIN 10.0.14393 Microsoft Windows Server 2016 Standard x64";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}