$re = '/"\w+"(?:\."\w+"){0,2}(?=\s*\()/m';
$str = 'CREATE TABLE "commerce"."finance"."invoices_1" (
"abc" NUMBER(15,0),
"def" VARCHAR2(200),
"ghi" DATE
);
CREATE TABLE "finance"."invoices_1" (
"abc" NUMBER(15,0),
"def" VARCHAR2(200),
"ghi" DATE
);
CREATE TABLE "invoices_1" (
"abc" NUMBER(15,0),
"def" VARCHAR2(200),
"ghi" DATE
);
CREATE TABLE "invoices_1" ( "abc" NUMBER(15,0),
"def" VARCHAR2(200),
"ghi" DATE
);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);