#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s{8,9}\d{1,2}\s{2}\|\s{9,10}\d{1,2}\s{2}\|\s{9,10}\d{1,2}$"
Local $sString = " 12 | 11 | 5" & @CRLF & _
" 13 | 3 | 13" & @CRLF & _
" 5 | 16 | 3" & @CRLF & _
" 15 | 2 | 20" & @CRLF & _
" 8 | 5 | 16" & @CRLF & _
" 4 | 12 | 3" & @CRLF & _
" 20 | 1 | 14" & @CRLF & _
" 9 | 1 | 1" & @CRLF & _
" 15 | 13 | 14" & @CRLF & _
" 15 | 1 | 1" & @CRLF & _
" 18 | 15 | 5" & @CRLF & _
" 5 | 1 | 18" & @CRLF & _
" 13 | 9 | 8" & @CRLF & _
" 16 | 1 | 1" & @CRLF & _
" 5 | 5 | 14" & @CRLF & _
" 7 | 17 | 10" & @CRLF & _
" 8 | 13 | 20" & @CRLF & _
" 12 | 2 | 20" & @CRLF & _
" 8 | 14 | 3" & @CRLF & _
" 14 | 11 | 18" & @CRLF & _
" 6 | 11 | 14" & @CRLF & _
" 19 | 12 | 3" & @CRLF & _
" 8 | 7 | 13" & @CRLF & _
" 8 | 3 | 20"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")