re = /^(?!.*[.]ocm$)(?=[a-zA-Z0-9][a-zA-Z0-9@._%+-]{5,253}$)[a-zA-Z0-9@._%+-]{1,64}@(?:(?=[a-zA-Z0-9-]{1,63}\.)[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*\.){1,8}[a-zA-Z]{2,63}$/m
str = 'blah@somewhere.com
blah@somewhere.ocm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end