import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^---$((.)*)^---$";
final String string = "---\n"
+ "Created: 20.07.2023\n"
+ "Tags: #kleiderschrank, #golf\n"
+ "---\n\n"
+ "# Kleiderschrank | Golf\n\n"
+ "## Polos kurz schwarz (#polo)\n"
+ "2018-11 | 2 x Under Armour Herren Performance Poloshirt, Schwarz, XL\n"
+ "0000-00 | Nike Polos Standard FIT XL black\n"
+ "0000-00 | AIRBUS Bremen XL black\n"
+ "2018-05 | Golfino Poloshirt kurz grün\n"
+ "2018-05 | Golfino Poloshirt kurz türkis\n"
+ "2016-07 | 4 x Decathlon Polos\n"
+ "0000-00 | Adidas Polo XL hellgrau\n"
+ "0000-00 | Adidas Polo L signalrot\n"
+ "0000-00 | Adidas Polo L signalrot\n\n"
+ "## Polos lang\n"
+ "2019-04 | Golfino Poloshirt lang\n\n"
+ "## Pullover (#pullover)\n"
+ "0000-00 | Decathlon Fleece XL hellgrau\n"
+ "0000-00 | Decathlon Fleece XL blau\n\n"
+ "## Windshields (#windshields)\n\n"
+ "2019-04 | Nike Herren-Golfjacke mit Synthetikfüllung XL Schwarz\n"
+ "2019-04 | Golfino Thermo Jacke gesteppt schwarz 56\n"
+ "2017-06 | Golfino Windshield Fleece Jacke black\n"
+ "0000-00 | Golfino Shell dunkelbau\n"
+ "2017-06 | Golfino ThermoShirt 1/2 Zip blau 54\n"
+ "0000-00 | Golfino Jacke schwarz\n\n"
+ "## Rain Shirts (#rainshirts)\n\n"
+ "0000-00 | FootJoy Hydrolite Rainshirt XL black\n"
+ "2015-09 | Under Armour Herren Golf Pullover Crestable Elements 1/2 Zip, Black, XL\n\n"
+ "## Westen (#westen)\n\n"
+ "2018-05 | Golfino Mikrofaser Weste Navy\n"
+ "2019-04 | Golfino Weste gesteppt schwarz 56\n\n"
+ "## Zipper lang (#zipper)\n"
+ "2018-05 | Golfino Troyer Zip schwarz lang\n"
+ "2018-05 | Golfino Troyer Zip blau lang\n"
+ "2018-05 | Golfino Troyer Zip grün lang\n"
+ "2018-05 | Golfino Troyer Zip rot lang\n"
+ "2018-05 | Golfino Troyer Zip rot lang\n\n"
+ "## Hosen (#hosen)\n"
+ "0000-00 | Golfino 54 schwarz\n"
+ "0000-00 | Alberto chino 54 schwarz\n"
+ "0000-00 | Adidas blau 32/34\n\n"
+ "## Schuhe\n"
+ "2018-08 | FootJoy Golfschuhe Contour Casual 45 braun\n"
+ "2018-08 | FootJoy Golfschuhe Contour Fit 45 schwarz\n"
+ "2015-09 | Nike\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}