$re = '/[A-Z][a-z]+|[A-Z]{2,}(?![a-z])/m';
$str = 'LazyDogASAPSleep
QuickFoxReadingPDF
A
The first letter is an A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);