import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1s(0x.*?)!8m";
final String string = "\n"
+ "# data-id: 1s(0x.*?)!8m\n"
+ "# latitude: !3d([-+]?.*?)!4d\n"
+ "# longitute: !4d([-+]?.*)!\n\n"
+ "https://www.google.com/maps/place/Burger+Madness+Seattle/@47.6062572,-122.4086176,12z/data=!4m9!1m2!2m1!1sseattle,+wa,+usa+burger!3m5!1s0x549041cdf279071f:0xb4634cde435eb7ec!8m2!3d-47.5666806!4d122.3299532!15sChdzZWF0dGxlLCB3YSwgdXNhIGJ1cmdlcloXIhVzZWF0dGxlIHdhIHVzYSBidXJnZXKSARRoYW1idXJnZXJfcmVzdGF1cmFudJoBI0NoWkRTVWhOTUc5blMwVkpRMEZuU1VSSmJFdDZWa2RuRUFF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}