import Foundation
// WARNING: You included a flag that Swift doesn't support: J
// Wehn this flag is set, it allows duplicated capturing group names.
// By default, Swift captures only the last value matched for a repeated capture group.
// As an alternative, the pattern can be modified to contain one capturing group per group you want to get in the result.
let pattern = ##"""
(?<= \s )
# Match opening braket (i.e., `[`).
(?<g1> \[)
# Match any single character (e.g., `x`).
(?<g2> .)
# Matching closing braket (i.e., `]`)
(?<g1> \])
(?= \s* [?!*]? \s* )
# Exclude entries without text (i.e., incl. in tables).
(?!
\s* [?!*]? \s* \|
|
\s* [?!*]? \s* $
)
# Match the text (i.e., capture based on modifier presence).
(?:
# Match modifier (i.e., `!`, `?`, or `*`) and the text that follows.
\s* (?<g3>[!?*]) \s* (?<g4>.*?)
|
# Match the text that does not follow a modifier.
\s* (?! [!?*]) \s* (?<g5>.*?)
)
# Match until either of the stops that follow are met.
(?= \s+ \^[a-z0-9]{6,} | \s+ \| | \s*$)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
# Should match
- [ ] Some task
- [ ] Some task | [[link]]
- [ ] Some task ^abcdef
- [ ] Some task | [[link]] ^abcdef
- [ ] ! Some task
- [ ] ! Some task | [[link]]
- [ ] ! Some task ^abcdef
- [ ] ! Some task | [[link]] ^abcdef
- [ ] Task one | [ ] ! Task two | [ ] Task three ^abcdef
| Tracker | Task | Backlog |
| ----------: | :---------------------- | :------- |
| 00:00-00:00 | [ ] Task item | [[linK]] |
| 00:00-00:00 | [ ] Task item ^abcdef | [[link]] |
| 00:00-00:00 | [ ] [[task-item]] | [[link]] |
| 00:00-00:00 | [ ] ! Task item | [[linK]] |
| 00:00-00:00 | [ ] ! Task item ^abcdef | [[link]] |
| 00:00-00:00 | [ ] ! [[task-item]] | [[link]] |
# Should not match
- [ ]
- [ ]
- [ ]
- [ ] !
- [ ] !
- [ ] !
| Tracker | Task | Backlog |
| ----------: | :---------------------- | :------- |
| 00:00-00:00 | [ ] | [[linK]] |
| 00:00-00:00 | [ ] ! | [[linK]] |
# Desired outcome
- group `notation`:
- match: `[` and `]`
- group `symbol`:
- match: any single character (e.g., `\s`) between `[` and `]`
- group `modifier`:
- match: `!`, `?`, or `*` that follows after `[ ]`
- group `text`:
- match: task text after `[ ]` without modifier present
- group `textmod`:
- match: task text after `[ ] !` with modifier present
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)