$re = '/(SET @@GLOBAL.GTID_PURGED=.*?\;)/m';
$str = 'SET @@SESSION.SQL_LOG_BIN= 0;
SET @@GLOBAL.GTID_PURGED=\'abae51b1-e1dc-11e8-bfd0-5665b72f6318:1-12559259\';
DROP TABLE IF EXISTS `app_users`;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);