import re
regex = re.compile(r"<li>([a-zA-Z]+)<br \/>([a-zA-Z]+)<\/li>", flags=re.MULTILINE)
test_str = ("<div class='post-header'>\n"
"<div class='post-header-line-1'></div>\n"
"</div>\n"
"<div class='post-body entry-content' id='post-body-210098160524748093' itemprop='articleBody'>\n"
"<div class=\"separator\" style=\"clear: right; float: right; margin-bottom: 1em; margin-left: 1em; text-align: center;\">\n"
"<br /></div>\n\n\n"
"<br />\n"
"<br />\n"
"<ul>\n"
"<li>Name<br />Location</li>\n"
"<li>Name<br />location</li>\n"
"<li>name<br />location</li>\n"
"<li>name<br />location</li>\n"
"</ul>\n"
"<br />\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")