re = /^(?:[A-Z]{1,8}|[A-Z]{8}\d)$/m
str = 'S3
FT5
FGTU7
ERTYUOP9
ERTGHYUKM
Correspond to:
E
ERT
RTYUKL
VBNDEFRW3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end