re = /(\w+): (.+?)(?:;|$)/m
str = 'customer: Anna Smith; payment: 123; date: 12-02-2020; customer: Jack; payment: 10.3; date: 20-03-2020'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end