#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[iI.\d+-])([+-]?(?:\d+(?:\.\d*)?|\.\d+)(?:[eE][+-]?\d+)?(?![iI.\d]))?([+-]?(?:(?:\d+(?:\.\d*)?|\.\d+)(?:[eE][+-]?\d+)?)?[iI])?$"
Local $sString = "1.1" & @CRLF & _
"" & @CRLF & _
"1.1+2.2i" & @CRLF & _
"" & @CRLF & _
"1.1-2.2i" & @CRLF & _
"" & @CRLF & _
"+2.2i" & @CRLF & _
"" & @CRLF & _
"-2.2i" & @CRLF & _
"" & @CRLF & _
"1.1+i" & @CRLF & _
"" & @CRLF & _
"1.1-i" & @CRLF & _
"" & @CRLF & _
"i" & @CRLF & _
"" & @CRLF & _
"-i" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")