package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+-\w+-(\d+)(\.\d+)+_(\d+\.)+\d+`)
var str = `DYYU-tx-6.7.9.7_6.1.1.0
DYYU-tx-6.7.9.7_60.11.11.09
DYYU-tx-60.70.90.70_6.1.1.0 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}