$re = '/^(?!.{16})(?=.*?\S{3})(?:[A-Za-z][a-z]* ?\b){1,3}$/m';
$str = 'Should match:
Yaw
yaw
James Bond
Monkey D Luffy
List item
Shouldn\'t match:
YaW
Two spaces
No no no
JamesBond';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);