using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\(?<id>[\d-]+)_\d+\.zip";
string input = @"G:\Archive\002443_20230526183639562.zip
G:\Archive\002446_20230526183334407.zip
G:\Archive\14967_20240703150011899.zip
G:\Archive\214_20231213150003676.zip
G:\Archive\34277_20230526200048891.zip
G:\Archive\48083_20240214150011919.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}