$re = '/"28": (true|false)/m';
$str = '{"1": true, "2": true, "3": true, "4": true, "5": true, "6": true, "7": true, "8": true, "9": true, "10": true, "11": true, "12": true, "13": true, "14": true, "15": true, "16": true, "17": true, "18": false, "19": false, "20": false, "21": false, "22": false, "23": false, "26": false, "27": false, "28": false, "29": false, "30": false, "31": false, "32": false, "33": false, "34": true, "35": true, "36": false, "37": true, "38": true, "39": false, "40": false, "41": false, "42": false, "81": false, "82": false}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);