$re = '/(?:\G(?!\A)|^foo)[^*]*\K\*/m';
$str = 'foo*arbaz*luj*abaz*lewis*bazbazlewbaz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);