re = /(?=.{2,18}$)
^@(?:@*-){0,10}@*@$/mx
str = '@@--@---@@-@-@
@--@-@---@-@@-@-@-@@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end