re = /(?=@(?:@*-){0,10}@*@$)
^.{2,18}$/mx
str = '@@--@---@@-@-@
@--@-@---@-@@-@-@-@@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end