re = /^(?!.*\*.*\*)(?:(?:\*|[A-Za-z\d\/]+)(?:,(?:[A-Za-z\d\/]+|\*))*)?$/m
str = 'ADSAD,*,adsad
*,adsds,asd123
Invalid:
**,asads
sasd,*,asa,*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end