# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?:\/\/\S*|((?:\(?(?:0{1,2}|\+)\d{1,2}\)?[ -]*)?\d(?:[ -]*\d){7,19})"
test_str = ("\n\n"
"https://asd.com/20441235534-aaaaaaaaaaa-\n\n"
"202460676\n\n"
"aasdasd 202460676\n\n"
"https://asd.com/20441235534\n\n\n"
"202460676-\n\n\n\n"
"10 text\n"
"1234 text\n"
"text 123\n\n"
"00491234567890\n"
"+491234567890\n\n"
"0123-4567890\n\n"
"0123 4567 789\n"
"0123 456 7890\n"
"0123 45 67 789\n\n"
"+490123 4567 789\n"
"+490123 456 7890\n"
"+49 123 45 67 789\n\n"
"123 4567 789\n"
"123 456 7890\n"
"123 45 67 789\n\n\n"
"+49 1234567890\n"
"+491234567890\n\n"
"0049 1234567890\n"
"0049 1234 567 890\n\n"
"(0049)1234567890\n"
"(+49)1234567890\n\n"
"(0049) 1234567890\n"
"(+49) 1234567890\n\n\n\n"
"text text (0049) 1234567890 text text\n"
"text text (+49) 1234567890 text text")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.