#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[?!#])[\w\W]*?(?=;)"
Local $sString = "#first line of text;" & @CRLF & _
"#second line of text;" & @CRLF & _
"#third line could easy " & @CRLF & _
"be on a new line;" & @CRLF & _
"#forth etc;" & @CRLF & _
"#this could (#hi,#hi,#hi) also " & @CRLF & _
"happen though:));" & @CRLF & _
"#so.... any idea;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")