$re = '/(?:[^\/]+\/){3}(\d{2})/';
$str = 'XXX/XXXX/XXXX/12YUX/YYY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);