import re
regex = re.compile(r"^([AQ]):(?:.|\n(?![AQ]:))+", flags=re.MULTILINE)
test_str = ("Q: This is a question. \n"
"Q: This is a 2nd question \n"
"on two lines.\n"
"A: This is an answer. \n"
"A: This is a 2nd answer \n"
"on two lines.\n"
"Q: Here's another question. \n"
"A: And another answer.\n\n"
"Testing.\n"
"123.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")