# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?P<Section>[A-Z]+\. .*(?:\n(?!\d|[A-Z]+\.).*)*)(?P<Subsections>(?:\n\d+\..*)*)"
test_str = ("1.1 SUMMARY\n"
"A. Furnish and install:\n"
"1. Soffit support framing.\n"
"2. Universal grid system.\n"
"3. Steel mesh infill.\n"
"B. Perform all drilling and cutting in miscellaneous metal items required for the\n"
"attachment of other items.\n"
"C. Perform all shop painting for all surfaces of exposed to view galvanized and non-\n"
"galvanized metals, and post-erection touch-up of shop prime coat, using the same\n"
"material as shop- prime coating.\n"
"D. Perform application of liquid zinc touch-up to all welds of galvanized steel items\n"
"furnished hereunder.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.