$re = '/^((0+?)|([\w\d]+))(\D)?(?!\D)(0+)?([1-9]?\d+)$/m';
$str = '01871-0001509
01871-432
0/0123456
0187115
0zDxx22321231cz/001240
01871-15
00187109
123-00456
123-00456
01871-15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);