package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0(?:-?\d){10}`)
var str = `However, some of them are written as "01-234-567-8-90", which technically is a 0 followed by 1
01234567890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}