#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-z]+)(?: *= *)(\d+|[A-z]+)$"
Local $sString = "Expression validator" & @CRLF & _
"^((?:[A-z]+)|((-|\+)?\d+))( +(\++|-+) +((?:-?\d+)|(?:[A-z]+)))*$" & @CRLF & _
"" & @CRLF & _
"Assignment validator" & @CRLF & _
"^([A-z]+)(?: *= *)(\d+|[A-z]+)$" & @CRLF & _
"" & @CRLF & _
"c= a" & @CRLF & _
"8" & @CRLF & _
"8 + 4" & @CRLF & _
"-2 + 4 - 5 + 6" & @CRLF & _
"" & @CRLF & _
"9 +++ - 10 -- 8" & @CRLF & _
"9 --- + 10" & @CRLF & _
"9 --- -10" & @CRLF & _
"9 +++ -10 -- 8" & @CRLF & _
"3 --- 5" & @CRLF & _
"14 - 12" & @CRLF & _
"-3 2" & @CRLF & _
"name = 44" & @CRLF & _
"a = 5" & @CRLF & _
"capName = 6 + 4" & @CRLF & _
"capName = 6" & @CRLF & _
"n = 3" & @CRLF & _
"m=4" & @CRLF & _
"a = 5" & @CRLF & _
"b = a" & @CRLF & _
"v= 7" & @CRLF & _
"n =9" & @CRLF & _
"c= a" & @CRLF & _
"A variable can have a name consisting of more than one letter." & @CRLF & _
"" & @CRLF & _
"count = 10" & @CRLF & _
"To print the value of a variable you should just type its name." & @CRLF & _
"" & @CRLF & _
"N = 5" & @CRLF & _
"N" & @CRLF & _
"5" & @CRLF & _
"It should be possible to set a new value to an existing variable." & @CRLF & _
"" & @CRLF & _
"a = 1" & @CRLF & _
"a = 2" & @CRLF & _
"a = 3" & @CRLF & _
"a" & @CRLF & _
"3" & @CRLF & _
"If an identifier or value of a variable is invalid, the program must print a message like the one below." & @CRLF & _
"" & @CRLF & _
"a1 = 8" & @CRLF & _
"Invalid identifier" & @CRLF & _
"n = a2a" & @CRLF & _
"Invalid assignment" & @CRLF & _
"a = 7 = 8" & @CRLF & _
"Invalid assignment" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")