$re = '/^(?:2[0-4]|[01]?[0-9]):[0-5]?[0-9]$/m';
$str = '03:39
3:39';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);