package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([?!"'~&%$*@#0-^@9]+)$`)
var str = `1.12
1
FOO9baz
&%$*@#
98&%$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}